Recent Widgets


Register for DashboardWidgets

Recent Forums Posts

Partners


iCompositions

MacDesktops.net

RSS Showcase
RSS Comments
RSS Forums

This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. Posted in: Widget Central

Widget won't display external image?

Author Message
TomGillespie



Joined: 23 Jul 2005
Posts: 3

Posted: Thu Aug 11, 2005 - 9:32 am    Post subject: Widget won't display external image? Reply with quote

In my widget, I use this IMG tag:
Code:
<img src='http://64.34.99.133/Pics?streamPotdThumbToday=y' style="width:114px; height:80px; position:absolute; top:31px; left:4px;">
to try to display the Picture of the day Thumbnail from Supercars.net.

When I view the HTML file it works perfectly, but when I view it in Dashboard the picture does not display. There is a image placeholder, but it is just transparent.

Can widgets display external images? Or is it that the source is a stream rather than an actual image file?

Thanks a lot!
View user's profile Send private message Send e-mail Widgets
Da_Vinci



Joined: 26 Apr 2005
Posts: 100

Posted: Thu Aug 11, 2005 - 9:53 am    Post subject: Reply with quote

I have the same problem!

Apple's widget manager displays the icon of every widget installed.
And if you load the widget in Safari and right-click on on icon you can see that the source is the "icon.png" file in the resources of the installed widget - just downsized.

You can find Apple's widget here:
file:///System/Library/CoreServices/Dock.app/Contents/Resources/Widgets.wdgt

A look at their source might help! Cool

Da_Vinci

Ps: If you got the workaround - could you tell me/us?
I'm not very familiar with JS
View user's profile Send private message Send e-mail Widgets
galendw



Joined: 30 May 2005
Posts: 71
Location: Here.

Posted: Thu Aug 11, 2005 - 10:02 am    Post subject: Re: Widget won't display external image? Reply with quote

TomGillespie wrote:
In my widget, I use this IMG tag:
Code:
<img src='http://64.34.99.133/Pics?streamPotdThumbToday=y' style="width:114px; height:80px; position:absolute; top:31px; left:4px;">
to try to display the Picture of the day Thumbnail from Supercars.net.

When I view the HTML file it works perfectly, but when I view it in Dashboard the picture does not display. There is a image placeholder, but it is just transparent.

Can widgets display external images? Or is it that the source is a stream rather than an actual image file?

Thanks a lot!


I had the same problem. You have to allow network access.

In your Info.plist file:
Code:
<key>AllowNetworkAccess</key>
<true/>

_________________
View user's profile Send private message Send e-mail Visit poster's website Widgets
Da_Vinci



Joined: 26 Apr 2005
Posts: 100

Posted: Thu Aug 11, 2005 - 10:12 am    Post subject: Reply with quote

Oh thanx!
View user's profile Send private message Send e-mail Widgets
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.

 
Powered by phpBB © 2001, 2002 phpBB Group