Recent Widgets


Register for DashboardWidgets

Recent Forums Posts

Partners


iCompositions

MacDesktops.net

RSS Showcase
RSS Comments
RSS Forums

Post new topic   Reply to topic Posted in: Support

Comments Problem

Author Message
jtbandes



Joined: 17 Jun 2005
Posts: 269
Location: Oregon

Posted: Wed Nov 30, 2005 - 9:12 pm    Post subject: Comments Problem Reply with quote

When looking at the comments for a widget, the 3 categories behave weirdly. The text thinks it's a link, but only acts partly as a link. Brown on mouse over, blue on mouse down, black when neither are true.
View user's profile Send private message Send e-mail Widgets
pm
Administrator


Joined: 24 Aug 2004
Posts: 398

Posted: Thu Dec 01, 2005 - 6:17 pm    Post subject: Reply with quote

I'm not really sure I understand fully, would you post a link to an example of where this is happening?
View user's profile Send private message Send e-mail Widgets
gnome
Administrator


Joined: 26 Sep 2004
Posts: 145

Posted: Thu Dec 01, 2005 - 9:50 pm    Post subject: Reply with quote

He means the href= attribute of the <a> tags are being destroyed. I'll look into it.
View user's profile Send private message Widgets
jtbandes



Joined: 17 Jun 2005
Posts: 269
Location: Oregon

Posted: Thu Dec 01, 2005 - 11:20 pm    Post subject: Reply with quote

gnome wrote:
He means the href= attribute of the <a> tags are being destroyed. I'll look into it.


I'm not sure you understand. If you look at the comments for a widget, and mouse over the 3 pulldown menus for rating the widget, the text next to them behaves partly like a link.
View user's profile Send private message Send e-mail Widgets
purvisa



Joined: 21 Jul 2005
Posts: 182
Location: Kirkland, WA

Posted: Fri Dec 02, 2005 - 5:30 am    Post subject: Reply with quote

The colors are the same ones used for link/visited (#2f549c), active (#5a3d23), and hover (#11f) as they appear in the defailt.css file for the site. However, it is not a link that is causing this odd behavior. Check this out:

The comments form is preceded by a plain anchor that looks like this:

Code:
<a name="addcom" />


It appears there was once the idea of providing a direct link to the comments area by way of a link (remember that the "a" in the tag simply means anchor and that the "href" is what tells it to resolve an address outside of the page).

Since this makes the entire portion after the anchor declaration part of an anchor tag, the style sheet is styling the text accordingly, treating it as if it were a link, when in fact it is normal text inside of an unused anchor.

That was fun! Can we do it again?
View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger Widgets
pm
Administrator


Joined: 24 Aug 2004
Posts: 398

Posted: Fri Dec 02, 2005 - 7:13 am    Post subject: Reply with quote

Ah, I see what you're saying. I suppose we have to have an actual close tag for the anchor.

It's been fixed Smile

Also, as for the problem Gnome mentioned, we're most likely going to start using BBcode in Showcase comments and descriptions (like the forums) so that'll be fixed.
View user's profile Send private message Send e-mail Widgets
Post new topic   Reply to topic

 
Powered by phpBB © 2001, 2002 phpBB Group