Recent Widgets


Register for DashboardWidgets

Recent Forums Posts

Partners


iCompositions

MacDesktops.net

RSS Showcase
RSS Comments
RSS Forums

This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. Posted in: Widget Development

encoding problem

Author Message
psajcho



Joined: 03 Sep 2007
Posts: 1

Posted: Mon Sep 03, 2007 - 4:21 am    Post subject: encoding problem Reply with quote

Hi. I have text on the website with utf-8 encoding. Widget connects to website by this function:
Code:

var request = new XMLHttpRequest();
var LOGIN="***";
var PASSWORD="***";
function setup() {
   var params="login=" + LOGIN + "&password=" + PASSWORD;
   request.open('POST',"http://api.grono.net/pub/apilogin/",false);
   request.setRequestHeader('Content-Type','application/x-www-form-urlencoded');
   request.send(params);
   request.setRequestHeader('Content-Type','text/html; charset=utf-8');
   request.open('GET',"http://api.grono.net/api/user/"+ LOGIN +"/status/",false);
   request.send(null);
   document.getElementById("blimp").innerHTML=request.responseText;
}

Widget set encoding to utf-8 but in facts is still iso-8859-1. wtf? I can't change encoding. In html file i have this:
Code:
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
And it's still the same. Please help me!
View user's profile Send private message Send e-mail Widgets
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.

 
Powered by phpBB © 2001, 2002 phpBB Group