Recent Widgets


Register for DashboardWidgets

Recent Forums Posts

Partners


iCompositions

MacDesktops.net

RSS Showcase
RSS Comments
RSS Forums

This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. Posted in: Widget Development

"Missing Info.plist" agony.

Author Message
yuetsu



Joined: 08 Mar 2009
Posts: 2
Location: Portland, Oregon

Posted: Tue Mar 10, 2009 - 6:21 pm    Post subject: "Missing Info.plist" agony. Reply with quote

hello all,

i'm having a real pain in the patoot trying to use dashcode under 10.5.6 leopard.

i launch dashcode to create a new countdown widget in Dashcode. i set all the widget attributes and mark that and the customize countdown options as done. i save. i then try and just run it, as is. each and every time i get the same error: "Cannot open widget: Missing Info.plist file." i check the "Files" view and yes, an Info.plist file *is* in there. also, it's properly named "Info.plist," capital "I," not lowercase "i" on "Info." (yes, i've seen those errors mentioned in these forums.

in addition, if i save everything, shut down dashcode, and re-open it, i then get a Canvas view screen with nothing but the blank, grey checkered canvas where the widget formerly was. and i haven't altered any files or changed a line of code.

i'm on a black macbook with an intel core2duo 2.16 Ghz process, 2 GB ram and mac os x 10.5.6 leopard with all the latest updates to the system applied, security updates and all else.

to make sure it wasn't my development install, i downloaded and installed the latest Xcode 3.1.2 package and iPhone SDK 2.2.1 package and installed them both. i still have the same problem after installing those, restarting, and doing the exact same steps above in Dashcode v. 2.0.1 (159). before this, this never happened to me in dashcode before.

any help as to what is happening here would be most appreciated. thank you.


faddah steve yuetsu wolf
portland, oregon


Mad Evil or Very Mad Sad Razz
View user's profile Send private message Send e-mail Visit poster's website AIM Address Widgets
yuetsu



Joined: 08 Mar 2009
Posts: 2
Location: Portland, Oregon

Posted: Mon Mar 23, 2009 - 11:28 am    Post subject: Still no word on "Missing Info.plist" error? Reply with quote

i posted this query a number of weeks ago and no one in this forum has even bothered to reply. i can't believe i'm the only one who has run into this problem using Xcode/Dashcode. Can anyone please help me in trouble shooting this? please see my original message for the problems and my set-up.

faddah steve yuetsu wolf
portland, oregon
View user's profile Send private message Send e-mail Visit poster's website AIM Address Widgets
Greenie



Joined: 08 Jun 2005
Posts: 81

Posted: Mon Mar 23, 2009 - 5:32 pm    Post subject: Reply with quote

Hi,

I am on a G4, so I am not sure if I could help anything. I tried to follow your steps and created the widget without any problems. The only thing I could think of right now would be that the file-permissions on the info.plist-file may be wrong (for whatever reason), so that Dashcode may not be able to open it. You could try to repair file-permissions via Disk-Utility, just to give it a try.

A few other things:

- you could tell *exactly* which steps you have taken to produce the widgets. List each one please, to make it possible for the people to follow exactly your steps

- what if you run the widget outside of Dashcode?

- what if you copy another Info.plist into the widget-folder and restart Dashcode?

- does the Console.app show any error-messages that could give a hint when you open/run the widget from within Dashcode?

- if you can, please upload the zipped Dashcode-Projectfile somewhere, so others can try it out.
View user's profile Send private message Send e-mail AIM Address ICQ NumberWidgets
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.

 
Powered by phpBB © 2001, 2002 phpBB Group