Recent Widgets


Register for DashboardWidgets

Recent Forums Posts

Partners


iCompositions

MacDesktops.net

RSS Showcase
RSS Comments
RSS Forums

This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. Posted in: Widget Development

Flash Widget doesn't appear

Author Message
Flu



Joined: 24 Nov 2009
Posts: 1

Posted: Tue Nov 24, 2009 - 1:32 pm    Post subject: Flash Widget doesn't appear Reply with quote

Hi everybody,

i'm vainly trying to embed my simple Flash 9 file to my widget.
I build the widget framework with dashcode and in whose testmode everything looks well. But when i build the dashboard release and install, only a black frame and the default-close button appears.
My main.html looks like that:

Code:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html>
<head>
    <meta http-equiv="content-type" content="text/html; charset=utf-8">
    <link rel="stylesheet" href="main.css">
    <script type="text/javascript" src="localizedStrings.js" charset="utf-8"></script>
    <script type="text/javascript" src="Parts/utilities.js" charset="utf-8"></script>
    <script type="text/javascript" src="Parts/setup.js" charset="utf-8"></script>
    <script type="text/javascript" src="Parts/Text.js" charset="utf-8"></script>
    <script type="text/javascript" src="main.js" charset="utf-8"></script>
</head>
<body onload="load();" apple-part="com.apple.Dashcode.part.StackLayout">
    <div id="front">
        <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" type="application/x-shockwave-flash" width="130" height="400" data="widget.swf" id="object" style="">
            <param name="movie" value="widget.swf">
            <param name="allowScriptAccess" value="always">
            <param name="quality" value="high">
            <param name="wmode" value="transparent">
            <embed src="widget.swf" quality="high" bgcolor="#ffffff" width="130" height="400" name="krueger_widget" allowScriptAccess="always" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
        </object>
    </div>
    <div id="back">
    </div>
</body>
</html>



Does anybody know, why the widget is only seen in the dashcode testmode and not in dashboard finally?

... sorry for my bad english Smile

Greets,

Dennis
View user's profile Send private message Send e-mail Widgets
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.

 
Powered by phpBB © 2001, 2002 phpBB Group