Recent Widgets


Register for DashboardWidgets

Recent Forums Posts

Partners


iCompositions

MacDesktops.net

RSS Showcase
RSS Comments
RSS Forums

This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. Posted in: Widget Central

Popup default changes to 1st item in project after debug run

Author Message
kwhitmore43



Joined: 15 Nov 2009
Posts: 2

Posted: Fri Jan 29, 2010 - 6:21 pm    Post subject: Popup default changes to 1st item in project after debug run Reply with quote

My widget has 2 popups that both are somehow changing their defaults every time the widget is quit in the dashcode debugger.

Sequence:
1. I set both of the popups' defaults to options further down the list.

2. I then save the project and run it using the debugger.

3. Without changing the popup selections, I click another element that runs a script that retrieves the popup values using the .object.getValue() function. The values retrieved are always the first option's values, no matter what I select.

4. I then click the stop button in the debugger.

5. The inspector now shows the popups' defaults as being the first options.
(Not 100% repeatable. I'm still trying to isolate the circumstances affect the repeatability.)

6. I look in the generated HTML and find no SELECT or OPTION elements. It's all generated on the fly, but I don't see where the option values and texts are stored in the project, so I can't identify whether it's actually saving the default indices I select in the inspector.

Any help to debug this would be greatly appreciated.
View user's profile Send private message Send e-mail Widgets
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.

 
Powered by phpBB © 2001, 2002 phpBB Group