Decorative - I Love Lamp

Description: Look, it's the most glorious rainbow ever!

Bring the 60's to your dashboard with I Love Lamp, a lava lamp widget that uses Quartz to render a non-stop stream of animated bubbles.

I Love Lamp uses an open source Quartz Composer Plugin. For more information on the plugin visit qcw-plugin.sourceforge.net.

I Love Lamp is a universal binary, as are all of our widgets.
Author: islayer
Version: 1.5
New in v1.5: - Far more efficient than version 1.1 (up to 20x more efficient!)
- More shapes and skins (7 in total now)
- New lava algorithm (the old algorithm has been kept in the "Red Classic" skin)
- The lava now pauses when dashboard is inactive and unpauses when it becomes active, rather than restarting
Uploaded on: January 28th 2006 at 9:16 AM
Rating: (4.2 stars)   [Show Detailed Ratings]
Downloads: 7666 (all versions), 6640 (this version)
    Download Now »

Comments

Sort

Can't get the plugin to work.

Posted by: SiliconX on Dec 23, 05 (2:59 PM) for version 1.0 (previous version)  

Yeah, I put them in the correct folder, and it didn't work. Then I restarted, and it dosn't give the plugin error message, but it doesn't do anything. smiley

And I just discovered that each time I show dashboard, the widget's translucent black middle section becomes darker, eventually becoming completely opaque.

Posted by: jtbandes on Dec 23, 05 (3:35 PM) for version 1.0 (previous version)  

I'm having the same results as jtbandes. I want my lava! smiley

Posted by: bkazez on Dec 23, 05 (3:38 PM) for version 1.0 (previous version)  

Can we have a lava-lamp less "phallic"-ish?

Posted by: Liquidrums on Dec 23, 05 (4:32 PM) for version 1.0 (previous version)  

Yes, adding a selectable range of shapes would be nice.

Posted by: jtbandes on Dec 23, 05 (4:38 PM) for version 1.0 (previous version)  

Yeah, I have the exact same results as jtbandes too. I tried putting the plugins in ~/Library/Internet Plug-ins and the Macintosh HD/Library/Internet Plugins and while on my HD, the widget didn't come up with the message, but got blacker and blacker everytime I opened Dashboard... Hm......

Posted by: goldenretriever123 on Dec 23, 05 (4:42 PM) for version 1.0 (previous version)  

I'm having the same problem. smiley

Posted by: EricNau on Dec 23, 05 (6:09 PM) for version 1.0 (previous version)  

odd, i didn't install the quartz plugins and it still worked... i just left them on my desktop. but every time i activate the dashboard, a dialog box comes up saying i need them, even though it clearly works without them (for me anyways). weird.

Posted by: andrethegiant on Dec 23, 05 (6:51 PM) for version 1.0 (previous version)  

ok, now i installed them (you have to take them out of the folder, for those of you who didn't) in /Library/Internet-Plugins, and it works beautifully. Thanks! Great widget! i would give it a perfect rating if the lava was more blob-like.

Posted by: andrethegiant on Dec 23, 05 (6:54 PM) for version 1.0 (previous version)   View Detailed Rating

[quote=andrethegiant]you have to take them out of the folder, for those of you who didn't
I did. I put them in the right place and everything, and had the problems I described above. smiley

Posted by: jtbandes on Dec 23, 05 (7:00 PM) for version 1.0 (previous version)  

It only works in "HD/Library/Internet Plug-Ins/"

It works great btw =)

Posted by: Rik on Dec 23, 05 (7:50 PM) for version 1.0 (previous version)   View Detailed Rating

Glad you guys worked it out in the end
They must be in /Library not ~/Library and it will work aslong as your system is quartz compatible

Posted by: islayer (developer) on Dec 23, 05 (9:23 PM) for version 1.0 (previous version)  

The plug-ins ARE in the Library folder on my HD (not home folder), and if my system isn't Quartz compatible, then I don't know what is.

Posted by: SiliconX on Dec 23, 05 (10:53 PM) for version 1.0 (previous version)  

Try opening a new copy of the widget.It will work in the end

Posted by: islayer (developer) on Dec 23, 05 (11:19 PM) for version 1.0 (previous version)  

Would be better if it worked in the beginning. =P

Posted by: SiliconX on Dec 23, 05 (11:49 PM) for version 1.0 (previous version)  

yeah i know but when you have to reley on 3rd party plugins there isnt alot you can do.if anything blame apple for not making quartz plugins themselfs

Good news is ive just finished a new version that has the plugin bundled which shoulds solve some issues

Posted by: islayer (developer) on Dec 23, 05 (11:57 PM) for version 1.0 (previous version)  

Just like I dreamed about when I first posted the request.

Thanks!

Posted by: EricNau on Dec 24, 05 (12:11 AM) for version 1.0 (previous version)   View Detailed Rating

Glad you like it.
Hopefully we can get it working even better in the future.
Still not bad for 24 hours work i guess smiley

Posted by: islayer (developer) on Dec 24, 05 (12:28 AM) for version 1.0 (previous version)  

My Quartz plug-in is in the right folder. The Console says "invalid drawable" when I open it.

Ben

Posted by: bkazez on Dec 24, 05 (4:04 AM) for version 1.0 (previous version)  

Ben,
Can you download the latest version from http://www.islayer.net
I updated it so the plugins are inside the widget.
If it doesnt work try deleting the plugins you installed manaully incase they are causing conflicts

Posted by: islayer (developer) on Dec 24, 05 (4:19 AM) for version 1.0 (previous version)  

Version 1.1 isn't far off. The liquid looks much better now, plus we've been working on the look of the lamp. It should also address the Quartz plugin issues.

Posted by: islayermarc on Dec 24, 05 (5:25 AM) for version 1.0 (previous version)  

the latest version works fine without external plugin, it's a nice useless widget, but it uses too much cpu.
anyway i suggest the possibility to choose the lava color (no cycles) and the shape of the lamp

great work

Posted by: 3mors on Dec 24, 05 (10:12 AM) for version 1.1 (previous version)   View Detailed Rating

Keep in mind that it only uses CPU while dash is open, so it's not really slowing your computer down. We've tested on an iMac G5, 2 12" PowerBooks and a G5. All seemed very respectable for what it's doing.

Skins (shape of the lamp) will come, as will pausing rather than restarting when dash is shown.

Posted by: islayermarc on Dec 24, 05 (10:51 AM) for version 1.1 (previous version)  

1.1 doesn't work for me. 1.0 did. I have a G5 and OSX 10.4.3.

Posted by: andrethegiant on Dec 24, 05 (9:45 PM) for version 1.1 (previous version)  

i know that it uses CPU only when dashboard is open, but i think it's not good anyway: this widget isn't the only one on my dashboard and so also the other widgets slow down when lava lamp is open

Posted by: 3mors on Dec 25, 05 (10:25 AM) for version 1.1 (previous version)  

3mors, it sounds like you don't have a GPU that's fully supported by CoreImage, causing the CPU to do a lot of the work. It doesn't slow my 1.33ghz 12" PB down at all.

Posted by: islayermarc on Dec 26, 05 (12:30 PM) for version 1.1 (previous version)  

It still doesn't work for me.

Posted by: jtbandes on Dec 27, 05 (9:47 PM) for version 1.1 (previous version)  

Why does the lava reset itself whenever I go in and out of Dashboard? I would prefer constant lava.

Posted by: minienvelope on Dec 28, 05 (1:01 PM) for version 1.1 (previous version)  

It's all good now. I deleted the widget and downloaded it from DBW again and it works. smiley

Posted by: jtbandes on Dec 29, 05 (1:39 AM) for version 1.1 (previous version)   View Detailed Rating

Great to hear jtbandes. minienvelope, the next version should fix that.

Posted by: islayermarc on Dec 29, 05 (11:19 PM) for version 1.1 (previous version)  

I don't like the shape and blobs.

Posted by: IanTheMacFan on Jan 01, 06 (6:30 PM) for version 1.1 (previous version)  

all of a sudden, after downloading mac os 10.4.4, this widget worked again. awesome.

Posted by: andrethegiant on Jan 11, 06 (4:32 AM) for version 1.1 (previous version)  

new version is on the way with many new features including a realistic lamp shape and pausing.
Plus upto 25x lower cpu usage !!

Posted by: islayer (developer) on Jan 14, 06 (2:36 AM) for version 1.1 (previous version)  

now the widget has a black box around the lava part - like it's not getting masked to the shape of the lamp. This happens for me on all the skins.

Posted by: andrethegiant on Jan 28, 06 (9:51 PM) for version 1.5 (current version)  

andrethegiant :: What mac are you using? It hasn't done that on any of the test systems. Do you have a CoreImage capable graphics card?

Posted by: islayermarc on Jan 28, 06 (11:49 PM) for version 1.5 (current version)  

I don't have a core image capable graphics card, and it works for me on my non-intel eMac.

Posted by: jtbandes on Jan 29, 06 (4:51 AM) for version 1.5 (current version)  

Installed, nothing happens, shows up for a second, then disappears. Console shows this error:

[9029] file:///Users/myusername/Library/Widgets/I%20Love%20Lamp.wdgt/ILoveLamp.html:TypeError - Value undefined (result of expression plugin.start) is not object.
2006-01-29 01:57:16.832 DashboardClient[9029] (com.iSlayer.ILoveLamp.widget) file:///Users/myusername/Library/Widgets/I%20Love%20Lamp.wdgt/ILoveLamp.html: TypeError - Value undefined (result of expression plugin.start) is not object. (line: 8)

DP G5 1.8Ghz

Posted by: funkdaddy on Jan 29, 06 (6:59 AM) for version 1.5 (current version)  

why don't you make the lava quicktime?
that way you don't need to worry about the plugin, I just don't know if you'll get the functionality you need.

Posted by: google636 on Jan 29, 06 (8:55 PM) for version 1.5 (current version)  

Doesn't work for me either =/

Posted by: elr on Feb 01, 06 (10:08 AM) for version 1.5 (current version)  

i'm on a 2.0GHz dual G5 with a 128Mb graphics card which is coreimage capable. weird.....

Posted by: andrethegiant on Feb 06, 06 (4:38 AM) for version 1.5 (current version)  

You Must Log In to Post Comments

 
Username:
Password:
Remember Me
Create an account | Password Reminder